Start a new topic
Solved

ORA-­12516

Problem


The following error is observed in the InfoBurst server log:


Failed to connect to repository, Attempt # 1/24 :: Unable to connect to database (ORA‐12516: TNS:listener could not find available handler with matching protocol stack)


Cause


Issue is specific to InfoBurst repository hosted in Oracle. The error is returned by the Oracle provider and may

occur during periods of heavy usage. The error may be indicative of insufficient available processes or sessions on the Oracle platform


Solution


Consult the Oracle DBA. It is recommend either the number of processes or sessions be increased to accommodate

requests from InfoBurst.


The following are sample commands to increase either the number of processes or sessions in Oracle and should

only be executed by or with the assistance of the Oracle DBA.


Increase number of sessions:


SQL> show parameters sessions

SQL> alter system set sessions=250 scope=spfile;


Increase number of processes:


SQL> show parameters processes

SQL> alter system set processes=200 scope=spfile;

Login or Signup to post a comment