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Unlock a Burst or XDC

Problem


A Burst or XDC appears with the lock indicator image when the Burst/XDC is not in an executing state.


Cause


The causes of a locked Burst or XDC may vary. Please open an InfoSol Helpdesk ticket for a specific diagnosis.


Solution

  • Confirm the Burst/XDC is not in an executing state
  • Select the Help-About icon
  • Select the Utilities panel
  • Select Enable Support Options
  • Locate the locked object, right-click and select Unlock It


Hi Bryan,


What is the corresponding solution for the HTML UI.


Thanks.

Hey Jessen. There are two reasons a Burst or XDC would display the "locked" status in the legacy Flash user interface:


  1. The Burst/XDC is running which means it is locked and cannot be edited.
  2. The Burst/XDC is not running, but the status in the repository is invalid.


#2 means there has been a system-level issue where the object status was not properly updated when it completed. This is typically due to an issue with the connection between InfoBurst and its database repository and that issue prevented the status from being properly updated.


The Flash user interface "unlock" option allows the user to reset the status of the object so that it can be used. Unfortunately, the user may cause a bigger issue if they try to unlock an object that is actually running. "Unlock" serves the same function as the IBResetSchedule utility available to administrators via command prompt.


We are not planning to provide the "unlock" feature in the HTML5 user interface. If an object is locked because of issue #2, then it can be unlocked using IBResetSchedule. The issue that caused #2 should be investigated. The goal should be to prevent the issue from occurring versus working around the issue using "unlock" or IBResetSchedule.

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