Start a new topic
Solved

Burst SET PARAMETER error "Value not found in Lov for Parameter'

An error similar to the one below occurs on the SET PARAMETER step in a burst activity log:


Error ==> Value 'California' not found in Lov for Parameter 'Enter values for State:' 


Before a WebI document refresh, InfoBurst requests the default LOV for a document parameter from BusinessObjects. Then InfoBurst will compare a parameter value supplied by the InfoBurst user to the default BusinessObjects LOV. If the value is not present in the default LOV, then InfoBurst will produce the above error.


The error is the result of the Parameter LOV Validation setting within the burst.


https://help.infosol.com/solution/articles/19000022697-document-options (see Parameter LOV Validation)


The setting is designed to prevent the user from passing a value that is not in the default LOV from BusinessObjects. If you intend to pass a value that is not in the default LOV, then you can change the setting "Off" to prevent the check and pass the value to BusinessObjects.


Oh ok. I see now.  Thanks for the information.


Rufina

From what I'm reading, the default LOV is a function of the report universe. The LOV can be either static or dynamic. 


https://michaelwelter.wordpress.com/2014/01/27/optimizing-universe-lists-of-values/


The downside to static is the list may become dated. The downside to dynamic is the overhead added by refreshing the LOV from the data source every time the LOV is viewed.


I recommend reviewing the universe design with the owner/designer of the universe.

Hi,


I was able to get the burst to work by changing the Parameter LOV validation to off. 


 But what I really want to know is Where do I find the Business Objects default LOV?  The only thing I can find is the 'Set default values' for the prompt.


Thanks,
Rufina

Hey Rufina. The issue you describe may be the result of Parameter LOV Validation.


https://help.infosol.com/a/solutions/categories/19000044327 (see Parameter LOV Validation)


When you choose to supply values to a parameter (entered manually or from a data source), InfoBurst will automatically compare that value to the default LOV it gets from BusinessObjects. If the value is not in the default LOV, InfoBurst will abort the burst and return the error you cite.


Sometimes the default LOV from BusinessObjects is dated and does not contain a value that you know to be valid. In such a case, you can disable Parameter LOV Validation and InfoBurst will simply pass the value you have supplied to BusinessObjects.


To disable Parameter LOV Validation:

  • Open the Burst
  • Select the document
  • Select the Options tab
  • Change Parameter LOV Validation to "Off"
  • Select Save

Hi,

I am creating a new burst that uses a spreadsheet to pass the parameters to a Webi report.

I am getting a similar error message - Value '/Univ_odsProd' not found in LOV for Parameter.  I have 6 parameters in the report and I am getting 3 of them failing with this error.


When I do turn off the parameter check setting as suggested in the ticket it does work.

Where do I find the Business Objects default LOV? The only thing I can find is the 'Set default values' for the prompt.


Login or Signup to post a comment