Start a new topic

Crystal EXPORT error "IDL:omg.org/CORBA/NO_RESPONSE:1.0 has been thrown. Reason for failing: ."

The following error occurs after a lengthy (40+ minute) REFRESH/EXPORT of a Crystal Report:


IDL:omg.org/CORBA/NO_RESPONSE:1.0 has been thrown.  Reason for failing: .


The error is internal to BusinessObjects. We have approached SAP about the issue, but no root cause has been identified. It appears the issue is specific to BI 4.2 clustered environments. SAP suggests the issue is a communications timeout between BusinessObjects server, but they have not provided specific guidance on resolving the issue.


SAP provided the following problem description and recommendation:


Crystal Reports is not a database archiving tool, use the Server to do that it's much more efficient and capable. Most times when this happens we can only suggest they break the amount of data being returned into smaller blocks. Nothing we can do for very large amounts of data other than to suggest you use smaller blocks. Or try scheduling them when not many people on the system. Another issue is with large amounts of data CR requires contiguous blocks of memory or it can cause these types of errors.


You may want to add more RAS services to lighten the RAS loading.


InfoSol consultants have provided some additional suggestions. These suggestions should be reviewed your BusinessObjects administrator for relevance to and impact on your specific BusinessObjects environment. You should also consider consulting SAP before making any of the changes listed below.


Review SAP KBA 2565920


The article suggests the error can occur intermittently when there are network issues. The article cites network issues like the firewall cache being full due to debugging turned on and left on and/or multiple NIC cards on a machine.


Review SAP KBA 2629743


SAP recommends the best approach in these scenarios with multiple VLAN, need to access the client tools from the WAN, or when the system has multiple network interfaces is to set the FQDN on EVERY service of BusinessObjects to make sure they are accessible externally and that the services can communicate between them (standalone) or from one machine to another (distributed environment), as well as between environments (ie: Promotion)


  1. Go to the Central Management Console (CMC) and logon
  2. Go to Servers
  3. Check the properties of the first service (example: Adaptive Job Server)
  4. In the "Common Settings" section, set the "Host Identifiers" section from "Auto-Assign" to "Hostname" and assign the FQDN of the interface that should be used by the end-users
  5. Repeat for every services in the platform


Also, consider making sure to set the correct FQDN alias in CMC > Applications



The downside:  Clients need to also be able to communicate to the machine.  Requiring the FQDN or the IP may mean the client tool needs to have that entry in their host file or other means of understanding for communication.


Increase Tomcat MaxThreads 


SAP recommends setting Tomcat MaxThreads to at least 300 (max. 900)

A busy server thread metric staying the same indicates it is at maximum.  There is an SAP reference to CORBA errors for Webi reports based on that so maybe….

- Maximum of possible threads (maxthread parameter in Tomcat). For Tomcat, it can be set to 900.  Recommendations say to at least up it to 300.


Example:


<!-- Define a non-SSL HTTP/1.1 Connector on port 8080 -->

    <Connector URIEncoding="UTF-8" acceptCount="100" connectionTimeout="20000" disableUploadTimeout="true" enableLookups="false" maxHttpHeaderSize="8192" maxSpareThreads="75" maxThreads="150" minSpareThreads="25" port="8080" redirectPort="8443"/>

    <!-- Note : To disable connection timeouts, set connectionTimeout value

     to 0 -->


We are not aware of a downside to increasing MaxThreads beyond the resources needed to support it.


1 Comment

Users also report a nightly restart of the RAS server(s) mitigates this issue.

Login or Signup to post a comment